Vishwanatha Subbanna | 55d8f76 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 1 | SUMMARY = "OpenPOWER Host checkstop monitor application" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit obmc-phosphor-systemd |
| 5 | inherit obmc-phosphor-license |
| 6 | inherit allarch |
| 7 | |
| 8 | DEPENDS += "virtual/obmc-gpio-monitor" |
| 9 | RDEPENDS_${PN} += "virtual/obmc-gpio-monitor" |
| 10 | |
| 11 | # For now, monitoring checkstop is the only usecase |
| 12 | OBMC_HOST_MONITOR_INSTANCES = "checkstop" |
| 13 | |
| 14 | # Copies config file having arguments for monitoring host checkstop |
| 15 | # via GPIO assertion |
| 16 | SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop" |
| 17 | |
Vishwanatha Subbanna | dda7444 | 2017-06-07 21:00:16 +0530 | [diff] [blame^] | 18 | STATES = "start stop" |
| 19 | CHECKSTOP_SERVICE_FMT = "openpower-host-checkstop-monitor-{0}@.target" |
| 20 | SYSTEMD_SERVICE_${PN} += "${@compose_list(d, 'CHECKSTOP_SERVICE_FMT', 'STATES')}" |
Vishwanatha Subbanna | 55d8f76 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 21 | |
Vishwanatha Subbanna | dda7444 | 2017-06-07 21:00:16 +0530 | [diff] [blame^] | 22 | CHECKSTOP_TMPL = "openpower-host-checkstop-monitor-{0}@.target" |
| 23 | CHECKSTOP_TGTFMT = "openpower-host-checkstop-monitor-{0}@{1}.target" |
| 24 | CHECKSTOP_MONITOR_FMT = "../${CHECKSTOP_TMPL}:obmc-host-{0}@{2}.target.wants/${CHECKSTOP_TGTFMT}" |
| 25 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'STATES', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}" |