blob: 3545018b3a0f03058076bb218ba4df317640dbef [file] [log] [blame]
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -05001SUMMARY = "Open POWER DBus Interfaces"
2DESCRIPTION = "Generated bindings, using sdbus++, for the openpower YAML"
3PR = "r1"
Patrick Venture542d1f72018-10-02 19:51:03 -07004PV = "1.0+git${SRCPV}"
Patrick Ventureec25fd52018-11-03 09:10:39 -07005LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -05007
8S = "${WORKDIR}/git"
9
10inherit autotools pkgconfig
Patrick Williamsd555f822020-03-31 16:43:15 -050011inherit python3native
Marri Devender Rao9f9431d2017-05-29 01:33:26 -050012inherit phosphor-dbus-yaml
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -050013
14DEPENDS += "autoconf-archive-native"
Patrick Williamsd555f822020-03-31 16:43:15 -050015DEPENDS += "${PYTHON_PN}-sdbus++-native"
Matt Spinler62390042019-07-25 11:00:49 -050016DEPENDS += "phosphor-dbus-interfaces"
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -050017
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -050018SRC_URI += "git://github.com/openbmc/openpower-dbus-interfaces"
Andrew Geisslerc43a57b2020-01-09 20:30:41 +000019SRCREV = "109ded04f3fec7bbbd93f9c9956a355f4894a51f"
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -050020
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -050021PACKAGECONFIG ??= "libopenpower_dbus"
22PACKAGECONFIG[libopenpower_dbus] = " \
23 --enable-libopenpower_dbus, \
24 --disable-libopenpower_dbus, \
25 systemd sdbusplus, \
Patrick Williamsd555f822020-03-31 16:43:15 -050026 libsystemd \
Deepak Kodihalli52bcaed2017-03-17 03:51:13 -050027 "
28
29PACKAGECONFIG_remove_class-native = "libopenpower_dbus"
30PACKAGECONFIG_remove_class-nativesdk = "libopenpower_dbus"
31
32BBCLASSEXTEND += "native nativesdk"