Vishwanatha Subbanna | 55d8f76 | 2017-04-28 15:35:10 +0530 | [diff] [blame] | 1 | SUMMARY = "OpenPOWER Host checkstop monitor application" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit obmc-phosphor-systemd |
| 5 | inherit obmc-phosphor-license |
| 6 | inherit allarch |
| 7 | |
| 8 | DEPENDS += "virtual/obmc-gpio-monitor" |
| 9 | RDEPENDS_${PN} += "virtual/obmc-gpio-monitor" |
| 10 | |
| 11 | # For now, monitoring checkstop is the only usecase |
| 12 | OBMC_HOST_MONITOR_INSTANCES = "checkstop" |
| 13 | |
| 14 | # Copies config file having arguments for monitoring host checkstop |
| 15 | # via GPIO assertion |
| 16 | SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/gpio/checkstop" |
| 17 | |
| 18 | SYSTEMD_SERVICE_${PN} += "openpower-host-checkstop-monitor@.target" |
| 19 | |
| 20 | CHECKSTOP_TMPL = "openpower-host-checkstop-monitor@.target" |
| 21 | CHECKSTOP_TGTFMT = "openpower-host-checkstop-monitor@{0}.target" |
| 22 | CHECKSTOP_MONITOR_FMT = "${CHECKSTOP_TMPL}:${CHECKSTOP_TGTFMT}" |
| 23 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'CHECKSTOP_MONITOR_FMT', 'OBMC_HOST_MONITOR_INSTANCES')}" |
| 24 | |
| 25 | GPIO_TMPL = "phosphor-gpio-monitor@.service" |
| 26 | MONITOR_TGTFMT = "openpower-host-checkstop-monitor@{0}.target" |
| 27 | GPIO_INSTFMT = "phosphor-gpio-monitor@{0}.service" |
| 28 | MONITOR_GPIO_FMT = "../${GPIO_TMPL}:${MONITOR_TGTFMT}.wants/${GPIO_INSTFMT}" |
| 29 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'MONITOR_GPIO_FMT', 'OBMC_HOST_MONITOR_INSTANCES')}" |