Deepak Kodihalli | abaa00b | 2017-02-05 10:10:44 -0600 | [diff] [blame] | 1 | SUMMARY = "Inventory config for openpower-vpd-parser" |
| 2 | PR = "r1" |
| 3 | |
| 4 | inherit native |
| 5 | inherit obmc-phosphor-license |
| 6 | inherit openpower-fru-vpd |
| 7 | |
| 8 | SRC_URI += "file://inventory" |
| 9 | |
| 10 | PROVIDES += "virtual/openpower-fru-inventory" |
| 11 | |
| 12 | S = "${WORKDIR}" |
| 13 | |
| 14 | do_install() { |
| 15 | # This recipe is supposed to create a systemd environment file |
| 16 | # with values for FRU types and paths. This example recipe |
| 17 | # uses a pre-defined file ($PN/inventory). |
| 18 | |
| 19 | DEST=${D}${inventory_datadir_native} |
| 20 | install -d ${DEST} |
| 21 | install inventory ${DEST} |
| 22 | } |