meta-phosphor: inventory: enable non-native recipes

There exists a number native class recipes throughout meta-phosphor
that simply provide a data (often YAML) file as input to building
another application.

Having these data file recipes implemented as native class recipes
prevents the use of machine overrides because bitbake (rightfully so)
discards machine qualifiers from native recipes.  Further, data files
aren't really any different than library header files and those are
consumed by recipes as target class recipes that are DEPENDed on.  Do
the same thing for data file recipes.

Change-Id: Ic1e648dbaf1dbf8156679d840331d9662c8a9c72
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb b/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
index 1b54dd5..520cdcc 100644
--- a/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
+++ b/recipes-phosphor/inventory/phosphor-inventory-manager_git.bb
@@ -15,7 +15,7 @@
 require phosphor-inventory-manager.inc
 
 DEPENDS += " \
-        ${PN}-config-native \
+        phosphor-inventory-manager-assettag \
         phosphor-dbus-interfaces \
         phosphor-dbus-interfaces-native \
         phosphor-logging \
@@ -33,11 +33,11 @@
 S = "${WORKDIR}/git"
 
 EXTRA_OECONF = " \
-        YAML_PATH=${STAGING_DIR_NATIVE}${base_datadir} \
+        YAML_PATH=${STAGING_DIR_HOST}${base_datadir} \
         BUSNAME=${OBMC_INVENTORY_MGR_IFACE} \
         INVENTORY_ROOT=${OBMC_INVENTORY_PATH} \
         IFACE=${OBMC_INVENTORY_MGR_IFACE} \
-        IFACES_PATH=${STAGING_DIR_NATIVE}${yaml_dir} \
+        IFACES_PATH=${STAGING_DIR_HOST}${yaml_dir} \
         "
 
 PACKAGECONFIG ??= ""