blob: a44258fa05e9967cdec3d2ffd3a7f24f3dd3315e [file] [log] [blame]
SUMMARY = "Phosphor DBUS to REST WSGI Application"
DESCRIPTION = "Phosphor DBUS to REST WSGI Application."
HOMEPAGE = "http://github.com/openbmc/phosphor-rest-server"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://${WORKDIR}/git/LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
inherit allarch
inherit obmc-phosphor-systemd
inherit setuptools
RRECOMMENDS_${PN} += "virtual-obmc-wsgihost"
RDEPENDS_${PN} += " \
python-xml \
python-dbus \
obmc-mapper \
python-bottle \
python-spwd \
pyphosphor-utils \
pyphosphor-dbus \
pyphosphor-wsgi-apps-ns \
"
SRC_URI += "git://github.com/openbmc/phosphor-rest-server"
SRCREV = "7bc6d8d39daebe3529c4c31a8caa0288dfb0ecd5"
S = "${WORKDIR}/git/module"
SYSTEMD_SERVICE_${PN} = ""
SYSTEMD_OVERRIDE_${PN} += "rest-dbus.conf:obmc-mapper.target.d/rest-dbus.conf"
SYSTEMD_ENVIRONMENT_FILE_${PN} += "obmc/wsgi_app"