Add virtual/phosphor-logging-callouts

This virtual generates mappings between sysfs device paths and inventory
items.

Add a native recipe that builds the configuration from MRW. Set this
recipe as the default for OpenPOWER systems.

Resolves openbmc/openbmc#1093
Resolves openbmc/openbmc#1249

Change-Id: If67b4ef0850910a076ca212197a4bd0e704d0266
Signed-off-by: Deepak Kodihalli <dkodihal@in.ibm.com>
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-phosphor/logging/phosphor-logging.bb b/common/recipes-phosphor/logging/phosphor-logging.bb
index 14f2e6e..1d059c4 100644
--- a/common/recipes-phosphor/logging/phosphor-logging.bb
+++ b/common/recipes-phosphor/logging/phosphor-logging.bb
@@ -8,6 +8,7 @@
 inherit obmc-phosphor-license
 inherit obmc-phosphor-dbus-service
 inherit phosphor-dbus-interfaces
+inherit phosphor-logging
 
 DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
 
@@ -17,6 +18,7 @@
 DEPENDS += "python-pyyaml-native"
 DEPENDS += "sdbusplus sdbusplus-native"
 DEPENDS += "phosphor-dbus-interfaces"
+DEPENDS += "virtual/phosphor-logging-callouts"
 RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
 PROVIDES += "virtual/obmc-logging-mgmt"
 RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
@@ -26,4 +28,9 @@
 
 S = "${WORKDIR}/git"
 
-EXTRA_OECONF = "YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir}"
+EXTRA_OECONF = " \
+        YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \
+        CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \
+        "
+
+TARGET_CXXFLAGS += "-DPROCESS_META"