blob: 14f2e6ebb5e34dc5ce487efbe602b0268ef6c2dc [file] [log] [blame]
Adriana Kobylak172fe102016-10-19 14:58:25 -05001SUMMARY = "Logging DBUS Object"
2DESCRIPTION = "Logging DBUS Object"
3HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
4PR = "r1"
5
6inherit autotools pkgconfig
7inherit pythonnative
8inherit obmc-phosphor-license
9inherit obmc-phosphor-dbus-service
Adriana Kobylakf40e1d82017-02-09 13:43:22 -060010inherit phosphor-dbus-interfaces
Adriana Kobylak172fe102016-10-19 14:58:25 -050011
12DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
13
14DEPENDS += "autoconf-archive-native"
15DEPENDS += "systemd"
16DEPENDS += "python-mako-native"
17DEPENDS += "python-pyyaml-native"
Patrick Williams57b17812016-12-09 08:56:38 -060018DEPENDS += "sdbusplus sdbusplus-native"
Adriana Kobylak78784092017-02-09 15:06:41 -060019DEPENDS += "phosphor-dbus-interfaces"
20RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
Adriana Kobylak172fe102016-10-19 14:58:25 -050021PROVIDES += "virtual/obmc-logging-mgmt"
22RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
23
24SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Williams5f0cbed2017-03-09 16:00:10 -060025SRCREV = "9cfe9f38d9ed2ddedea6d58040bed6bfc0831f08"
Adriana Kobylak172fe102016-10-19 14:58:25 -050026
27S = "${WORKDIR}/git"
28
Adriana Kobylakf40e1d82017-02-09 13:43:22 -060029EXTRA_OECONF = "YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir}"