blob: c7b2be94807dc740a29cf1540562e91ae639b068 [file] [log] [blame]
Adriana Kobylak172fe102016-10-19 14:58:25 -05001SUMMARY = "Logging DBUS Object"
2DESCRIPTION = "Logging DBUS Object"
3HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
4PR = "r1"
5
6inherit autotools pkgconfig
7inherit pythonnative
8inherit obmc-phosphor-license
9inherit obmc-phosphor-dbus-service
10
11DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "systemd"
15DEPENDS += "python-mako-native"
16DEPENDS += "python-pyyaml-native"
17PROVIDES += "virtual/obmc-logging-mgmt"
18RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
19
20SRC_URI += "git://github.com/openbmc/phosphor-logging"
21SRCREV = "c830e0f492c50e712c2bf1589e0282eebb4107ab"
22
23S = "${WORKDIR}/git"
24