Default channel config JSON data

Added default configuration JSON files for all
channel information, includes
 1) Channel common config
 2) Channel access (volatile & non-volatile) data

Change-Id: Iaf3a28ee7814d5c9895f9d2b55c3c9ac8c3c6c6a
Signed-off-by: AppaRao Puli <apparao.puli@intel.com>
Signed-off-by: Richard Marian Thomaiyar <richard.marian.thomaiyar@linux.intel.com>
diff --git a/recipes-phosphor/ipmi/phosphor-ipmi-config.bb b/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
index 2cba63d..96e977c 100644
--- a/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
+++ b/recipes-phosphor/ipmi/phosphor-ipmi-config.bb
@@ -11,6 +11,8 @@
     file://dcmi_sensors.json \
     file://dev_id.json \
     file://power_reading.json \
+    file://channel_access.json \
+    file://channel_config.json \
     "
 
 FILES_${PN} = " \
@@ -19,6 +21,8 @@
     ${datadir}/ipmi-providers/dcmi_sensors.json \
     ${datadir}/ipmi-providers/dev_id.json \
     ${datadir}/ipmi-providers/power_reading.json \
+    ${datadir}/ipmi-providers/channel_access.json \
+    ${datadir}/ipmi-providers/channel_config.json \
     "
 
 do_fetch[noexec] = "1"
@@ -38,4 +42,9 @@
         ${D}${datadir}/ipmi-providers/dev_id.json
     install -m 0644 -D ${WORKDIR}/power_reading.json \
         ${D}${datadir}/ipmi-providers/power_reading.json
+    install -m 0644 -D ${WORKDIR}/channel_access.json \
+        ${D}${datadir}/ipmi-providers/channel_access.json
+    install -m 0644 -D ${WORKDIR}/channel_config.json \
+        ${D}${datadir}/ipmi-providers/channel_config.json
+
 }