| SUMMARY = "Phosphor OpenBMC BT to DBUS" |
| DESCRIPTION = "Phosphor OpenBMC BT to DBUS." |
| PR = "r1" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| |
| inherit autotools pkgconfig |
| inherit obmc-phosphor-dbus-service |
| |
| DBUS_SERVICE_${PN} = "org.openbmc.HostIpmi.service" |
| |
| PROVIDES += "virtual/obmc-host-ipmi-hw" |
| RPROVIDES_${PN} += "virtual-obmc-host-ipmi-hw" |
| RRECOMMENDS_${PN} += "phosphor-ipmi-host" |
| |
| DEPENDS += "autoconf-archive-native" |
| DEPENDS += "systemd" |
| RDEPENDS_${PN} += "libsystemd" |
| |
| S = "${WORKDIR}/git" |
| SRC_URI += "git://github.com/openbmc/btbridge" |
| SRCREV="68bcce035ac7029d3110b53fb07848067da56b40" |
| |
| # This is how linux-libc-headers says to include custom uapi headers |
| CFLAGS_append = " -I ${STAGING_KERNEL_DIR}/include/uapi" |
| do_configure[depends] += "virtual/kernel:do_shared_workdir" |