blob: 31b1e6fa783ce3bd643d7f7f6809f3a8eb817665 [file] [log] [blame]
SUMMARY = "Phosphor Time Manager daemon"
DESCRIPTION = "Daemon to cater to BMC and HOST time management"
HOMEPAGE = "http://github.com/openbmc/phosphor-time-manager"
PR = "r1"
LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
inherit autotools pkgconfig pythonnative
inherit obmc-phosphor-dbus-service
DEPENDS += "autoconf-archive-native"
DEPENDS += "phosphor-mapper"
DEPENDS += "systemd"
DEPENDS += "sdbusplus"
DEPENDS += "sdbusplus-native"
DEPENDS += "phosphor-logging"
DEPENDS += "phosphor-dbus-interfaces"
RDEPENDS_${PN} += "${VIRTUAL-RUNTIME_obmc-settings-mgmt}"
RDEPENDS_${PN} += "network"
RDEPENDS_${PN} += "libmapper"
RDEPENDS_${PN} += "libsystemd"
RDEPENDS_${PN} += "sdbusplus"
RDEPENDS_${PN} += "phosphor-dbus-interfaces"
SRC_URI += "git://github.com/openbmc/phosphor-time-manager"
SRCREV = "75710b6a1a78cb81dd4fd2f3271f398a42179599"
S = "${WORKDIR}/git"
DBUS_SERVICE_${PN} += "xyz.openbmc_project.Time.Manager.service"