u-boot: rename u-boot.inc to u-boot-ubi.inc

Rename u-boot.inc to u-boot-ubi.inc to make it slightly clearer
that the include file is for ubi related things.

Use _append rather than += to avoid losing patches if SRC_URI is set
later during parse.

Change-Id: Ibb5c632bccf29a6a21056f280ebb3041c366347f
Tested: Built witherspoon and palmetto images.
Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
diff --git a/common/recipes-bsp/u-boot/u-boot_2016.07.bb b/common/recipes-bsp/u-boot/u-boot_2016.07.bb
index bcb95fe..0360f23 100644
--- a/common/recipes-bsp/u-boot/u-boot_2016.07.bb
+++ b/common/recipes-bsp/u-boot/u-boot_2016.07.bb
@@ -1,5 +1,5 @@
 require recipes-bsp/u-boot/u-boot.inc
 require u-boot-common.inc
-require u-boot.inc
+require u-boot-ubi.inc
 
 DEPENDS += "dtc-native"