meta-phosphor: ipmi-flash: add config hardware options

Add PACKAGECONFIG options for the various hardware options supported.
Although a configuration will require setting specific configuration
flags, the use of PACKAGECONFIGs reduces the amount of specific
configuration options manually set.  By reducing the number of manually
set options, the overall configuration can be simpler.

Signed-off-by: Patrick Venture <venture@google.com>
Change-Id: I7b16712339e26a2c54851bb643f900aaa3739232
diff --git a/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb b/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
index 1450264..92ed337 100644
--- a/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
+++ b/recipes-phosphor/ipmi/phosphor-ipmi-flash_git.bb
@@ -24,6 +24,11 @@
 PACKAGECONFIG[reboot-update] = "--enable-reboot-update, --disable-reboot-update"
 PACKAGECONFIG[host-bios] = "--enable-host-bios, --disable-host-bios"
 
+# Hardware options to enable transmitting the data from the host.
+PACKAGECONFIG[aspeed-p2a] = "--enable-aspeed-p2a, --disable-aspeed-p2a"
+PACKAGECONFIG[aspeed-lpc] = "--enable-aspeed-lpc, --disable-aspeed-lpc"
+PACKAGECONFIG[nuvoton-lpc] = "--enable-nuvoton-lpc, --disable-nuvoton-lpc"
+
 EXTRA_OECONF = "--disable-tests --disable-build-host-tool"
 
 S = "${WORKDIR}/git"