blob: 1450264906a5c8f9ea234514b68c872c67af33ed [file] [log] [blame]
Patrick Venture2ff2ecc2018-11-09 18:27:28 -08001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
2SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
4PR = "r1"
Patrick Venturee4e8e7b2019-06-28 15:34:15 -07005PV = "1.0+git${SRCPV}"
Patrick Venture2ff2ecc2018-11-09 18:27:28 -08006LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
Andrew Geisslera560e8e2019-07-08 19:51:12 +000011inherit systemd
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080012
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "phosphor-ipmi-blobs"
15DEPENDS += "phosphor-logging"
16DEPENDS += "sdbusplus"
Andrew Geisslera560e8e2019-07-08 19:51:12 +000017DEPENDS += "systemd"
Patrick Venturef0bb2a92019-03-07 10:51:53 -080018DEPENDS += "ipmi-blob-tool"
Patrick Venturecb35b592019-05-03 10:35:28 -070019DEPENDS += "pciutils"
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080020
Andrew Geissler67a224f2019-06-19 18:52:19 +000021PACKAGECONFIG ?= "cleanup-delete"
22PACKAGECONFIG[cleanup-delete] = "--enable-cleanup-delete, --disable-cleanup-delete"
Patrick Venture1e8155c2019-06-28 19:28:28 -070023# If using static-layout, reboot-update is a good option to handle updating.
24PACKAGECONFIG[reboot-update] = "--enable-reboot-update, --disable-reboot-update"
Andrew Geisslera560e8e2019-07-08 19:51:12 +000025PACKAGECONFIG[host-bios] = "--enable-host-bios, --disable-host-bios"
Andrew Geissler67a224f2019-06-19 18:52:19 +000026
Patrick Venturef65a4e22019-05-15 12:19:16 -070027EXTRA_OECONF = "--disable-tests --disable-build-host-tool"
28
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080029S = "${WORKDIR}/git"
30SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
Andrew Geisslerd61d6c12019-07-18 22:31:19 +000031SRCREV = "298930a18d01b4685aab3a7018299c7342afa028"
Andrew Geisslera560e8e2019-07-08 19:51:12 +000032
33SYSTEMD_PACKAGES = "${PN}"
34SYSTEMD_SERVICE_${PN} += "phosphor-ipmi-flash-bmc-prepare.target \
35 phosphor-ipmi-flash-bmc-verify.target \
36 phosphor-ipmi-flash-bmc-update.target"
37
38# If they enabled host-bios, add those three extra targets.
39HOST_BIOS_TARGETS = "phosphor-ipmi-flash-bios-prepare.target \
40 phosphor-ipmi-flash-bios-verify.target \
41 phosphor-ipmi-flash-bios-update.target"
42
43SYSTEMD_SERVICE_${PN} += "${@bb.utils.contains('PACKAGECONFIG', 'host-bios', '${HOST_BIOS_TARGETS}', '', d)}"
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080044
45FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
46FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
47FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
48
49BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"
Andrew Geissler67a224f2019-06-19 18:52:19 +000050BLOBIPMI_PROVIDER_LIBRARY += "${@bb.utils.contains('PACKAGECONFIG', 'cleanup-delete', 'libfirmwarecleanupblob.so', '', d)}"
Patrick Venturee21be192019-05-08 07:43:10 -070051
52do_configure[depends] += "virtual/kernel:do_shared_workdir"