blob: eb8fe0e73269c2df04cf95c666ee312cd698f90d [file] [log] [blame]
Patrick Venture2ff2ecc2018-11-09 18:27:28 -08001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
2SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-blobs"
14DEPENDS += "phosphor-logging"
15DEPENDS += "sdbusplus"
Patrick Venturef0bb2a92019-03-07 10:51:53 -080016DEPENDS += "ipmi-blob-tool"
Patrick Venturecb35b592019-05-03 10:35:28 -070017DEPENDS += "pciutils"
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080018
Patrick Venturef65a4e22019-05-15 12:19:16 -070019EXTRA_OECONF = "--disable-tests --disable-build-host-tool"
20
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080021S = "${WORKDIR}/git"
22SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
Andrew Geissler342fa6d2019-05-13 16:12:06 +000023SRCREV = "699750dedaaad4639ce3c831aed7d897f3572fbe"
Patrick Venture2ff2ecc2018-11-09 18:27:28 -080024
25FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
26FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
27FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
28
29BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"
Patrick Venturee21be192019-05-08 07:43:10 -070030
31do_configure[depends] += "virtual/kernel:do_shared_workdir"