Systemd: backport a new api for uuid generation

The current uuid generation method just export the machine-id,
it does not match the systemd description
(https://www.freedesktop.org/software/systemd/man/machine-id.html):
This ID uniquely identifies the host. It should be considered
"confidential", and must not be exposed in untrusted environments,
in particular on the network. If a stable unique identifier that is
tied to the machine is needed for some application, the machine ID
or any part of it must not be used directly.

Backport the new sd_id128_get_machine_app_specific from systemd 233,
to replace the old uuid generation method.

Change-Id: I44e7b32ca951a9fa591761c3a3e4f27da04d2b6f
Signed-off-by: Yong Li <yong.b.li@linux.intel.com>
diff --git a/common/recipes-core/systemd/systemd_%.bbappend b/common/recipes-core/systemd/systemd_%.bbappend
index 52edfc5..3208ae3 100644
--- a/common/recipes-core/systemd/systemd_%.bbappend
+++ b/common/recipes-core/systemd/systemd_%.bbappend
@@ -17,6 +17,9 @@
 SRC_URI += "file://0006-journal-Create-journald-dbus-object.patch"
 SRC_URI += "file://0007-journal-Add-Synchronize-dbus-method.patch"
 SRC_URI += "${@mf_enabled(d, 'obmc-ubi-fs', 'file://software.conf')}"
+SRC_URI += "file://0008-man-update-machine-id-5-with-a-note-about-privacy-46.patch"
+SRC_URI += "file://0009-sd-id128-add-new-sd_id128_get_machine_app_specific-A.patch"
+SRC_URI += "file://0010-core-add-khash-API-to-src-basic-as-wrapper-around-ke.patch"
 
 RRECOMMENDS_${PN} += "obmc-targets"
 FILES_${PN} += "${libdir}/systemd/network/default.network"