blob: 52edfc5c103aceec57ec2b21cce0b6e22d03c08c [file] [log] [blame]
Sergey Solomin89eaea22016-08-16 14:18:18 -05001FILES_${PN}-catalog-extralocales = \
2 "${exec_prefix}/lib/systemd/catalog/*.*.catalog"
3PACKAGES =+ "${PN}-catalog-extralocales"
Jayanth Othayothe6d21d92017-09-21 19:50:57 -05004PACKAGECONFIG_append = " networkd coredump"
Sergey Solomin89eaea22016-08-16 14:18:18 -05005PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight localed \
6 quotacheck kdbus ima smack polkit logind bootchart utmp"
Brad Bishopd4716b52015-10-30 03:02:05 -04007FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
8SRC_URI += "file://default.network"
Andrew Geissler51d40142017-09-07 14:32:45 -05009SRC_URI += "file://service-restart-policy.conf"
Brad Bishopc8442242016-08-15 20:16:55 -040010SRC_URI += "file://0001-Export-message_append_cmdline.patch"
Edward A. James7875c7e2016-10-14 16:07:14 -050011SRC_URI += "file://0002-systemd-Make-pam-compile-shared-library.patch"
Brad Bishop5083ec32017-01-11 20:42:58 -050012SRC_URI += "file://0003-basic-Factor-out-string-checking-from-name_to_prefix.patch"
13SRC_URI += "file://0004-basic-Use-path-escaping-when-mangling-path-instances.patch"
Ratan Guptabd3edb72017-07-20 12:08:11 +053014#TODO upstream the below patch via below issue
15#https://github.com/openbmc/openbmc/issues/2016
16SRC_URI += "file://0005-dont-return-error-if-unable-to-create-network-namespace.patch"
Adriana Kobylakc97b08b2017-06-04 15:41:59 -050017SRC_URI += "file://0006-journal-Create-journald-dbus-object.patch"
18SRC_URI += "file://0007-journal-Add-Synchronize-dbus-method.patch"
Gunnar Mills8b1ac4f2017-11-01 14:09:04 -050019SRC_URI += "${@mf_enabled(d, 'obmc-ubi-fs', 'file://software.conf')}"
Brad Bishopd4716b52015-10-30 03:02:05 -040020
Brad Bishope94b9152016-08-08 20:21:44 -040021RRECOMMENDS_${PN} += "obmc-targets"
Brad Bishopd4716b52015-10-30 03:02:05 -040022FILES_${PN} += "${libdir}/systemd/network/default.network"
Andrew Geissler51d40142017-09-07 14:32:45 -050023FILES_${PN} += "${libdir}/systemd/system.conf.d/service-restart-policy.conf"
Brad Bishopd4716b52015-10-30 03:02:05 -040024
Edward A. James561f6252016-08-04 16:19:18 -050025EXTRA_OECONF += " --disable-hwdb"
26
Brad Bishopd4716b52015-10-30 03:02:05 -040027do_install_append() {
28 install -m 644 ${WORKDIR}/default.network ${D}${libdir}/systemd/network/
Andrew Geissler51d40142017-09-07 14:32:45 -050029 install -m 644 -D ${WORKDIR}/service-restart-policy.conf ${D}${libdir}/systemd/system.conf.d/service-restart-policy.conf
Adriana Kobylakabd70962016-01-30 11:12:10 -060030
31 #TODO Remove after this issue is resolved
32 #https://github.com/openbmc/openbmc/issues/152
33 ln -s /dev/null ${D}/etc/systemd/system/systemd-hwdb-update.service
Gunnar Mills8b1ac4f2017-11-01 14:09:04 -050034
35 # /tmp/images is the software image upload directory.
36 # It should not be deleted since it is watched by the Image Manager
37 # for new images.
38 if ${@bb.utils.contains('MACHINE_FEATURES', 'obmc-ubi-fs', 'true', 'false', d)}; then
39 install -m 0644 ${WORKDIR}/software.conf ${D}${exec_prefix}/lib/tmpfiles.d/
40 fi
Brad Bishopd4716b52015-10-30 03:02:05 -040041}