blob: 0fd2931e1d3dd2f287e0a634009de7d23ea8b67f [file] [log] [blame]
Brad Bishop6fe81732016-06-23 13:28:00 -04001PACKAGECONFIG_append = " networkd"
2PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight quotacheck localed kdbus ima smack polkit"
Brad Bishopd4716b52015-10-30 03:02:05 -04003FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
4SRC_URI += "file://default.network"
Brad Bishopbb0b0fc2016-07-07 15:51:27 -04005SRC_URI += "file://obmc-standby.target"
Brad Bishopc8442242016-08-15 20:16:55 -04006SRC_URI += "file://0001-Export-message_append_cmdline.patch"
Brad Bishopd4716b52015-10-30 03:02:05 -04007
8FILES_${PN} += "${libdir}/systemd/network/default.network"
Brad Bishopbb0b0fc2016-07-07 15:51:27 -04009FILES_${PN} += "${systemd_system_unitdir}/obmc-standby.target"
Brad Bishopd4716b52015-10-30 03:02:05 -040010
Edward A. James561f6252016-08-04 16:19:18 -050011EXTRA_OECONF += " --disable-hwdb"
12
Brad Bishopd4716b52015-10-30 03:02:05 -040013do_install_append() {
14 install -m 644 ${WORKDIR}/default.network ${D}${libdir}/systemd/network/
Brad Bishopbb0b0fc2016-07-07 15:51:27 -040015 install -m 644 ${WORKDIR}/obmc-standby.target ${D}${systemd_system_unitdir}
16 ln -sf ../obmc-standby.target \
17 ${D}${systemd_system_unitdir}/multi-user.target.wants/obmc-standby.target
Adriana Kobylakabd70962016-01-30 11:12:10 -060018
19 #TODO Remove after this issue is resolved
20 #https://github.com/openbmc/openbmc/issues/152
21 ln -s /dev/null ${D}/etc/systemd/system/systemd-hwdb-update.service
Brad Bishopd4716b52015-10-30 03:02:05 -040022}