blob: e2995dc20d015934ab64e0ddd198cd6e1a675637 [file] [log] [blame]
Brad Bishop6fe81732016-06-23 13:28:00 -04001PACKAGECONFIG_append = " networkd"
2PACKAGECONFIG_remove = "machined hibernate ldconfig binfmt backlight quotacheck localed kdbus ima smack polkit"
Brad Bishopd4716b52015-10-30 03:02:05 -04003FILESEXTRAPATHS_append := "${THISDIR}/${PN}:"
4SRC_URI += "file://default.network"
Brad Bishopbb0b0fc2016-07-07 15:51:27 -04005SRC_URI += "file://obmc-standby.target"
Brad Bishopd4716b52015-10-30 03:02:05 -04006
7FILES_${PN} += "${libdir}/systemd/network/default.network"
Brad Bishopbb0b0fc2016-07-07 15:51:27 -04008FILES_${PN} += "${systemd_system_unitdir}/obmc-standby.target"
Brad Bishopd4716b52015-10-30 03:02:05 -04009
10do_install_append() {
11 install -m 644 ${WORKDIR}/default.network ${D}${libdir}/systemd/network/
Brad Bishopbb0b0fc2016-07-07 15:51:27 -040012 install -m 644 ${WORKDIR}/obmc-standby.target ${D}${systemd_system_unitdir}
13 ln -sf ../obmc-standby.target \
14 ${D}${systemd_system_unitdir}/multi-user.target.wants/obmc-standby.target
Adriana Kobylakabd70962016-01-30 11:12:10 -060015
16 #TODO Remove after this issue is resolved
17 #https://github.com/openbmc/openbmc/issues/152
18 ln -s /dev/null ${D}/etc/systemd/system/systemd-hwdb-update.service
Brad Bishopd4716b52015-10-30 03:02:05 -040019}