| SUMMARY = "OpenBMC console daemon" |
| DESCRIPTION = "Daemon to handle UART console connections" |
| HOMEPAGE = "http://github.com/openbmc/obmc-console" |
| PR = "r1" |
| |
| inherit obmc-phosphor-license |
| inherit obmc-phosphor-systemd |
| inherit autotools |
| |
| TARGET_CFLAGS += "-fpic -O2" |
| |
| SRC_URI += "git://github.com/openbmc/obmc-console" |
| SRC_URI += "file://${PN}.conf" |
| |
| SRCREV = "87e344cd6bd848f886e226c8d58ffe4da77ce4bc" |
| |
| SYSTEMD_SERVICE_${PN} = " \ |
| ${PN}.service \ |
| ${PN}-ssh.socket \ |
| ${PN}-ssh@.service \ |
| " |
| |
| do_install_append() { |
| install -m 0755 -d ${D}${sysconfdir} |
| install -m 0644 ${WORKDIR}/${PN}.conf ${D}${sysconfdir}/${PN}.conf |
| } |
| |
| S = "${WORKDIR}/git" |