blob: 26eea2a7d91891b75ef080c97d768be5b3e77994 [file] [log] [blame]
SUMMARY = "Phosphor OpenBMC WriteFRU for OpenPOWER systems"
DESCRIPTION = "Phosphor OpenBMC WriteFRU for OpenPOWER based systems"
HOMEPAGE = "https://github.com/openbmc/ipmi-fru-parser"
PR = "r1"
RRECOMMENDS_${PN} = "virtual/obmc-phosphor-host-ipmi-hw"
inherit obmc-phosphor-license
DEPENDS += "systemd \
host-ipmid \
"
RDEPENDS_${PN} += "libsystemd"
TARGET_CFLAGS += "-std=gnu++14"
SRC_URI += "git://github.com/openbmc/ipmi-fru-parser"
SRCREV = "1c779b8570849a52dac828538c36a59798f4583a"
FILES_${PN} += "${libdir}/host-ipmid/*.so"
FILES_${PN}-dbg += "${libdir}/host-ipmid/.debug"
S = "${WORKDIR}/git"
do_install() {
install -m 0755 -d ${D}${libdir}/host-ipmid
install -m 0755 ${S}/*.so ${D}${libdir}/host-ipmid/
}