| SUMMARY = "Phosphor OpenBMC event and error logging" |
| DESCRIPTION = "An error and event log daemon application, and \ |
| supporting tools for OpenBMC." |
| HOMEPAGE = "https://github.com/openbmc/phosphor-logging" |
| PR = "r1" |
| |
| inherit autotools pkgconfig |
| inherit pythonnative |
| inherit obmc-phosphor-license |
| inherit obmc-phosphor-dbus-service |
| inherit phosphor-logging |
| inherit phosphor-dbus-yaml |
| |
| DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service" |
| |
| DEPENDS += "autoconf-archive-native" |
| DEPENDS += "systemd" |
| DEPENDS += "python-mako-native" |
| DEPENDS += "python-pyyaml-native" |
| DEPENDS += "sdbusplus sdbusplus-native" |
| DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native" |
| DEPENDS += "virtual/phosphor-logging-callouts" |
| DEPENDS += "phosphor-logging-error-logs-native" |
| DEPENDS += "cereal" |
| RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
| PROVIDES += "virtual/obmc-logging-mgmt" |
| RPROVIDES_${PN} += "virtual-obmc-logging-mgmt" |
| |
| PACKAGE_BEFORE_PN = "${PN}-test" |
| FILES_${PN}-test = "${bindir}/*-test" |
| |
| SRC_URI += "git://github.com/openbmc/phosphor-logging" |
| SRCREV = "0a71badd000b6c1c76e08a684902bed4eabb6d6a" |
| |
| S = "${WORKDIR}/git" |
| |
| PACKAGECONFIG ??= "metadata-processing" |
| PACKAGECONFIG[metadata-processing] = " \ |
| --enable-metadata-processing, \ |
| --disable-metadata-processing, , \ |
| " |
| |
| EXTRA_OECONF = " \ |
| YAML_DIR=${STAGING_DIR_NATIVE}${yaml_dir} \ |
| CALLOUTS_YAML=${STAGING_DIR_NATIVE}${callouts_datadir}/callouts.yaml \ |
| " |