Add phosphor-host-check and required host services

This application and services will be used by the host reset service
to determine if the host is running after a BMC has been rebooted

Change-Id: I8299546b0f275ebbb46aa775ab7b0633cc3fd5e0
Signed-off-by: Andrew Geissler <andrewg@us.ibm.com>
diff --git a/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb b/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
index 3dcba8a..f3212cd 100644
--- a/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
+++ b/common/recipes-phosphor/packagegroups/packagegroup-obmc-apps.bb
@@ -17,6 +17,7 @@
         ${PN}-leds \
         ${PN}-sensors \
         ${PN}-software \
+        ${PN}-host-check-mgmt \
         "
 
 SUMMARY_${PN}-bmc-state-mgmt = "BMC state management"
@@ -29,6 +30,11 @@
         ${VIRTUAL-RUNTIME_obmc-chassis-state-manager} \
         "
 
+SUMMARY_${PN}-host-check-mgmt = "Host state check on bmc reset"
+RDEPENDS_${PN}-host-check-mgmt = " \
+        ${VIRTUAL-RUNTIME_obmc-host-check} \
+        "
+
 SUMMARY_${PN}-extras = "Extra features"
 RDEPENDS_${PN}-extras = " \
         phosphor-rest \