| SUMMARY = "Temp placeholder for skeleton function" |
| DESCRIPTION = "Temp placeholder for skeleton repository" |
| HOMEPAGE = "http://github.com/openbmc/skeleton" |
| PR = "r1" |
| |
| inherit obmc-phosphor-license |
| inherit obmc-phosphor-systemd |
| inherit obmc-phosphor-chassis-mgmt |
| inherit obmc-phosphor-fan-mgmt |
| inherit obmc-phosphor-flash-mgmt |
| inherit obmc-phosphor-policy-mgmt |
| inherit obmc-phosphor-sensor-mgmt |
| inherit obmc-phosphor-system-mgmt |
| |
| DEPENDS += "glib-2.0 systemd" |
| RDEPENDS_${PN} += "python-subprocess python-compression libsystemd" |
| SRC_URI += "git://github.com/openbmc/skeleton" |
| |
| # RDEPEND on pflash if the openpower-pflash machine feature is set. |
| PACKAGECONFIG ??= "${@bb.utils.contains('MACHINE_FEATURES', 'openpower-pflash', 'openpower-pflash', '', d)}" |
| PACKAGECONFIG[openpower-pflash] = ",,,pflash" |
| |
| SRCREV = "d3e6edc748f026dcd68d20306a1cfe0e26df22a9" |
| |
| S = "${WORKDIR}" |
| |
| do_compile() { |
| oe_runmake -C git |
| |
| # Remove deprecated files. |
| rm ${S}/git/bin/pflash |
| } |
| |
| do_install() { |
| source=${S}/git |
| |
| install -d ${D}/${sbindir} ${D}${libdir} |
| for i in ${source}/bin/*; do |
| install $i ${D}/${sbindir} |
| done |
| for i in ${source}/lib/*; do |
| install $i ${D}/${libdir} |
| done |
| } |