| SUMMARY = "FRU properties config for ipmi-fru-parser" |
| PR = "r1" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658" |
| |
| inherit native |
| inherit phosphor-ipmi-fru |
| |
| SRC_URI += "file://extra-properties.yaml" |
| |
| PROVIDES += "virtual/phosphor-ipmi-fru-properties" |
| |
| S = "${WORKDIR}" |
| |
| do_install() { |
| # This recipe is supposed to create an output yaml file with |
| # FRU property values extracted from the MRW. This example recipe |
| # provides a sample output file. |
| |
| DEST=${D}${properties_datadir} |
| install -d ${DEST} |
| install extra-properties.yaml ${DEST} |
| } |