blob: d35f26ccc1bac7f60147233a4bfc52d77ca5143e [file] [log] [blame]
SUMMARY = "Network DBUS object"
DESCRIPTION = "Network DBUS object"
HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-systemd
inherit obmc-phosphor-sdbus-service
SYSTEMD_SERVICE_${PN} += "network.service network-update-dns.service"
RDEPENDS_${PN} += "python-dbus python-pygobject"
SRC_URI += "git://github.com/openbmc/phosphor-networkd"
SRCREV = "c69c3d30fd7d5fd04ba990788b6d75b19f275fc8"
S = "${WORKDIR}/git"
do_install() {
install -d ${D}/${sbindir}
install ${S}/netman.py ${D}/${sbindir}
install ${S}/netman_watch_dns ${D}/${sbindir}
}