| SUMMARY = "Phosphor User Manager Daemon" |
| DESCRIPTION = "Daemon that does user management" |
| HOMEPAGE = "http://github.com/openbmc/phosphor-user-manager" |
| PR = "r1" |
| PV = "1.0+git${SRCPV}" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
| |
| inherit autotools pkgconfig |
| inherit obmc-phosphor-dbus-service |
| |
| DEPENDS += "autoconf-archive-native" |
| DEPENDS += "sdbusplus" |
| DEPENDS += "phosphor-logging" |
| DEPENDS += "phosphor-dbus-interfaces" |
| DEPENDS += "boost" |
| DEPENDS += "nss-pam-ldapd" |
| RDEPENDS_${PN} += "libsystemd" |
| RDEPENDS_${PN} += "phosphor-logging" |
| |
| inherit useradd |
| |
| USERADD_PACKAGES = "${PN}" |
| # add groups needed for privilege maintenance |
| GROUPADD_PARAM_${PN} = "priv-admin; priv-operator; priv-user; priv-callback " |
| |
| DBUS_SERVICE_${PN} += "xyz.openbmc_project.User.Manager.service" |
| |
| SRC_URI += "git://github.com/openbmc/phosphor-user-manager" |
| SRCREV = "9891f2f8f330cfe678098342bd1cb536e5810233" |
| S = "${WORKDIR}/git" |