blob: b2acc1c3b82f1d2b4ab5b883ea6dfd2acec19dcf [file] [log] [blame]
DESCRIPTION = "Linux kernel for OpenBMC"
SECTION = "kernel"
LICENSE = "GPLv2"
KBRANCH ?= "dev-4.3"
KCONFIG_MODE="--alldefconfig"
SRC_URI = "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
LINUX_VERSION ?= "4.3"
LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
SRCREV="openbmc-20160120-1"
PV = "${LINUX_VERSION}+git${SRCPV}"
COMPATIBLE_MACHINE_${MACHINE} = "openbmc"
inherit kernel
require recipes-kernel/linux/linux-yocto.inc
do_patch_append() {
for DTB in "${KERNEL_DEVICETREE}"; do
DT=`basename ${DTB} .dtb`
if [ -r "${WORKDIR}/${DT}.dts" ]; then
cp ${WORKDIR}/${DT}.dts \
${STAGING_KERNEL_DIR}/arch/${ARCH}/boot/dts
fi
done
}