blob: 6cdf398e50a4a6e840eb17a6227704f574f3fa05 [file] [log] [blame]
SUMMARY = "Phosphor OpenBMC Event Management"
DESCRIPTION = "Phosphor OpenBMC event management reference implementation."
HOMEPAGE = "https://github.com/openbmc/phosphor-event"
PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-event-mgmt
inherit obmc-phosphor-sdbus-service
inherit obmc-phosphor-c-daemon
SRC_URI += "git://github.com/openbmc/phosphor-event"
SRCREV = "aa9ec3aa2cc59fc7e2437041d89b19f4a8f1d7f0"
RDEPENDS_${PN} += "libsystemd"
DEPENDS += "systemd"
S = "${WORKDIR}/git"
INSTALL_NAME = "event_messaged"
do_install() {
install -m 0755 -d ${D}${sbindir}
install -m 0755 ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-eventd
}