rebase ipmitool to use upstream git

Upstream ipmitool has been under active development for a while now.
This includes adding the D-Bus interface to ipmitool as an option as
well as a mechanism to set the default interface. So now, building
ipmitool for openbmc is possible directly from upstream. The new patch
that is included in this commit has been pushed upstream and in under
review. It is needed to build in environments that don't have internet
access.

Tested-by: build ipmitool, run it on the BMC and see that it works
           bitbake ipmitool; scp <>/ipmitool <....>:/tmp;
	   /tmp/ipmitool mc info
	   /tmp/ipmitool -h
	   ...
	   Interfaces:
                   open          Linux OpenIPMI Interface
                   imb           Intel IMB Interface
                   lan           IPMI v1.5 LAN Interface
                   lanplus       IPMI v2.0 RMCP+ LAN Interface
                   serial-terminal  Serial Interface, Terminal Mode
                   serial-basic  Serial Interface, Basic Mode
                   dbus          OpenBMC D-Bus interface [default]

Change-Id: I61a3dbee98d86d33e032319a6e9ec63da63dab4a
Signed-off-by: Vernon Mauery <vernon.mauery@linux.intel.com>
diff --git a/recipes-phosphor/ipmi/ipmitool_%.bbappend b/recipes-phosphor/ipmi/ipmitool_%.bbappend
index 7a34ce4..5f25f5d 100644
--- a/recipes-phosphor/ipmi/ipmitool_%.bbappend
+++ b/recipes-phosphor/ipmi/ipmitool_%.bbappend
@@ -2,4 +2,17 @@
 
 DEPENDS += "systemd"
 
-SRC_URI += "file://0001-plugins-Add-a-backend-for-the-OpenBMC-dbus-interface.patch"
+SRC_URI = "git://github.com/ipmitool/ipmitool.git;protocol=https"
+SRCREV = "d818c2ff85c011be29c8d3047e516a5e032a1923"
+
+# this patch has been submitted to ipmitool upstream and is in review
+SRC_URI += " \
+    file://0001-create_pen_list-only-print-if-values-are-set.patch \
+    "
+
+S = "${WORKDIR}/git"
+LIC_FILES_CHKSUM = "file://${S}/COPYING;md5=9aa91e13d644326bf281924212862184"
+
+EXTRA_OECONF_append = " --enable-intf-dbus DEFAULT_INTF=dbus "
+
+PV = "1.8.18+git${SRCPV}"