| SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities" |
| LICENSE = "GPLv2+" |
| LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6" |
| SECTION = "bootloader" |
| DEPENDS = "mtd-utils" |
| |
| SRCREV = "f9b2a49f57c153c7358f9769234c0cefdf4de8d4" |
| UBRANCH = "v2016.07-aspeed-openbmc" |
| SRC_URI = "git://git@github.com/openbmc/u-boot.git;branch=${UBRANCH};protocol=https" |
| |
| PV = "v2016.07+git${SRCPV}" |
| |
| S = "${WORKDIR}/git" |
| |
| INSANE_SKIP_${PN} = "already-stripped" |
| EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1' |
| EXTRA_OEMAKE_class-cross = 'ARCH=${TARGET_ARCH} CC="${CC} ${CFLAGS} ${LDFLAGS}" V=1' |
| |
| inherit uboot-config |
| |
| do_compile () { |
| oe_runmake ${UBOOT_MACHINE} |
| oe_runmake env |
| } |
| |
| do_install () { |
| install -d ${D}${base_sbindir} |
| install -d ${D}${sysconfdir} |
| install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv |
| install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv |
| install -m 0644 ${S}/tools/env/fw_env.config ${D}${sysconfdir}/fw_env.config |
| } |
| |
| do_install_class-cross () { |
| install -d ${D}${bindir_cross} |
| install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_printenv |
| install -m 755 ${S}/tools/env/fw_printenv ${D}${bindir_cross}/fw_setenv |
| } |
| |
| SYSROOT_PREPROCESS_FUNCS_class-cross = "uboot_fw_utils_cross" |
| uboot_fw_utils_cross() { |
| sysroot_stage_dir ${D}${bindir_cross} ${SYSROOT_DESTDIR}${bindir_cross} |
| } |
| |
| PACKAGE_ARCH = "${MACHINE_ARCH}" |
| BBCLASSEXTEND = "cross" |