blob: dfdd3e3644b53c3e7b869250740fb2ee25763660 [file] [log] [blame]
SUMMARY = "Network DBUS object"
DESCRIPTION = "Network DBUS object"
HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-dbus-service
DBUS_SERVICE_${PN} += "org.openbmc.NetworkManager.service"
SYSTEMD_SERVICE_${PN} += "network-update-dns.service"
DEPENDS += "systemd"
RDEPENDS_${PN} += "python-dbus python-pygobject python-ipy"
SRC_URI += "git://github.com/openbmc/phosphor-networkd"
SRCREV = "c8d216a1ec0935a7149720c5bc1d6514c5d933bc"
S = "${WORKDIR}/git"
do_install_append() {
install -d ${D}/${sbindir}
install ${S}/netman.py ${D}/${sbindir}
install ${S}/netman_watch_dns ${D}/${sbindir}
}