blob: aeb0707c49d6307f5ae79aeaf6f51c6fa9e7e3d8 [file] [log] [blame]
SUMMARY = "Phosphor OpenBMC Event Management"
DESCRIPTION = "Phosphor OpenBMC event management reference implementation."
HOMEPAGE = "https://github.com/openbmc/phosphor-event"
PR = "r1"
inherit obmc-phosphor-license
inherit obmc-phosphor-event-mgmt
inherit obmc-phosphor-sdbus-service
inherit obmc-phosphor-c-daemon
TARGET_CPPFLAGS += "-std=c++11 -fpic"
SRC_URI += "git://github.com/openbmc/phosphor-event"
SRCREV = "d4a7217f42f065396e509b94940319261682f144"
RDEPENDS_${PN} += "libsystemd"
DEPENDS += "systemd"
S = "${WORKDIR}/git"
INSTALL_NAME = "event_messaged"
do_install() {
install -d ${D}/var/lib/obmc/events/
install -m 0755 -d ${D}${sbindir}
install -m 0755 ${S}/${INSTALL_NAME} ${D}/${sbindir}/obmc-phosphor-eventd
}