blob: 601993148cd44e899c2316e612f9b490dd9722ce [file] [log] [blame]
Wenzong Fan9eb3f612015-08-14 03:11:24 -04001SUMMARY = "Python module for handling IPv4 and IPv6 Addresses and Networks"
Andrew Geisslerf2308422017-10-27 14:10:50 -05002DESCRIPTION = "IPy is a Python module for handling IPv4 and IPv6 Addresses and Networks \
Wenzong Fan9eb3f612015-08-14 03:11:24 -04003in a fashion similar to perl's Net::IP and friends. The IP class allows \
4a comfortable parsing and handling for most notations in use for IPv4 \
5and IPv6 Addresses and Networks."
6SECTION = "devel/python"
7HOMEPAGE = "https://github.com/haypo/python-ipy"
8DEPENDS = "python"
9LICENSE = "BSD"
10LIC_FILES_CHKSUM = "file://COPYING;md5=ebc0028ff5cdaf7796604875027dcd55"
11
Andrew Geisslerf2308422017-10-27 14:10:50 -050012SRC_URI = "https://pypi.python.org/packages/source/I/IPy/IPy-${PV}.tar.gz"
Wenzong Fan9eb3f612015-08-14 03:11:24 -040013
14SRC_URI[md5sum] = "7b8c6eb4111b15aea31b67108e769712"
15SRC_URI[sha256sum] = "61da5a532b159b387176f6eabf11946e7458b6df8fb8b91ff1d345ca7a6edab8"
16
17S = "${WORKDIR}/IPy-${PV}"
18
19inherit distutils
20
21# need to export these variables for python-config to work
22export BUILD_SYS
23export HOST_SYS
24export STAGING_INCDIR
25export STAGING_LIBDIR
26
27BBCLASSEXTEND = "native"
28
29do_install_append() {
30 install -d ${D}/${datadir}/doc/${BPN}-${PV}
31 install AUTHORS COPYING ChangeLog README ${D}/${datadir}/doc/${BPN}-${PV}
32}