Andrew Geissler | 630736e | 2018-07-16 11:50:58 -0700 | [diff] [blame] | 1 | inherit obmc-phosphor-systemd |
| 2 | inherit useradd |
| 3 | |
| 4 | USERADD_PACKAGES = "${PN}" |
| 5 | |
| 6 | # add a user called httpd for the server to assume |
| 7 | USERADD_PARAM_${PN} = "-r -s /usr/sbin/nologin bmcweb" |
| 8 | |
| 9 | LICENSE = "Apache-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://LICENCE;md5=a6a4edad4aed50f39a66d098d74b265b" |
| 11 | |
| 12 | SRC_URI = "git://github.com/openbmc/bmcweb.git" |
| 13 | |
| 14 | PV = "1.0+git${SRCPV}" |
Andrew Geissler | 796efb0 | 2018-08-15 14:00:04 -0500 | [diff] [blame] | 15 | SRCREV = "eb1eb78e639414bf0862e4c2fee5ab65c1d2f314" |
Andrew Geissler | 630736e | 2018-07-16 11:50:58 -0700 | [diff] [blame] | 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | DEPENDS = "openssl zlib boost libpam sdbusplus gtest nlohmann-json libtinyxml2 " |
| 20 | |
| 21 | FILES_${PN} += "${datadir}/** " |
| 22 | |
| 23 | inherit cmake |
| 24 | |
| 25 | EXTRA_OECMAKE = "-DBMCWEB_BUILD_UT=OFF -DYOCTO_DEPENDENCIES=ON" |
| 26 | |
| 27 | SYSTEMD_SERVICE_${PN} += "bmcweb.service bmcweb.socket" |
| 28 | |
| 29 | FULL_OPTIMIZATION = "-Os -pipe " |
| 30 | |
| 31 | do_install_append() { |
| 32 | rm -rf ${D}${includedir}/dbus |
| 33 | rm -rf ${D}${libdir}/cmake |
| 34 | } |