blob: 90af32b52c16b5a87c715625804e703f5ae0e985 [file] [log] [blame]
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -06001SUMMARY = "Network DBUS object"
2DESCRIPTION = "Network DBUS object"
3HOMEPAGE = "http://github.com/openbmc/phosphor-networkd"
4PR = "r1"
5
Matthew Barth2ece5742016-09-28 13:14:43 -05006inherit autotools pkgconfig
Ratan Gupta05787732017-04-28 10:12:54 +05307inherit pythonnative
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -06008inherit obmc-phosphor-license
Brad Bishopbce1a792016-09-06 20:37:22 -04009inherit obmc-phosphor-dbus-service
vishwab18b1332016-06-20 06:41:52 -050010
Brad Bishopbce1a792016-09-06 20:37:22 -040011DBUS_SERVICE_${PN} += "org.openbmc.NetworkManager.service"
12SYSTEMD_SERVICE_${PN} += "network-update-dns.service"
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -060013
Matthew Barth95cd1b22016-10-24 12:51:20 -050014DEPENDS += "systemd"
Matthew Barth2ece5742016-09-28 13:14:43 -050015DEPENDS += "autoconf-archive-native"
Ratan Gupta05787732017-04-28 10:12:54 +053016DEPENDS += "sdbusplus sdbusplus-native"
17DEPENDS += "phosphor-dbus-interfaces phosphor-dbus-interfaces-native"
18DEPENDS += "phosphor-logging"
19
Matthew Barth95cd1b22016-10-24 12:51:20 -050020RDEPENDS_${PN} += "libsystemd"
Patrick Williams0b551752016-08-15 15:59:36 -050021RDEPENDS_${PN} += "python-dbus python-pygobject python-ipy"
Ratan Gupta05787732017-04-28 10:12:54 +053022RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces"
23RDEPENDS_${PN} += "phosphor-logging"
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -060024
Adriana Kobylak47544772016-02-03 17:34:16 -060025SRC_URI += "git://github.com/openbmc/phosphor-networkd"
Patrick Williamsf38bcd72017-03-24 10:20:03 -050026SRCREV = "968d203ef934d68ded7e026d38dc77835116dedd"
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -060027
28S = "${WORKDIR}/git"
29
Brad Bishopbce1a792016-09-06 20:37:22 -040030do_install_append() {
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -060031 install -d ${D}/${sbindir}
32 install ${S}/netman.py ${D}/${sbindir}
Ratan Gupta0f636982016-10-24 22:48:11 -050033 install ${S}/conf/network-manager.conf ${D}/${sysconfdir}
Adriana Kobylak8f2f3b32016-01-30 10:41:48 -060034}