Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Post Code Daemon" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Post Code Daemon" |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit autotools pkgconfig |
| 6 | inherit obmc-phosphor-systemd |
| 7 | |
| 8 | DEPENDS += "autoconf-archive-native" |
| 9 | DEPENDS += "sdbusplus" |
| 10 | DEPENDS += "phosphor-dbus-interfaces" |
| 11 | DEPENDS += "systemd" |
| 12 | |
| 13 | RDEPENDS_${PN} += "sdbusplus phosphor-dbus-interfaces" |
| 14 | |
Benjamin Fair | 8c605cf | 2018-06-29 13:00:14 -0700 | [diff] [blame] | 15 | SNOOP_DEVICE ?= "aspeed-lpc-snoop0" |
| 16 | POST_CODE_BYTES ?= "1" |
| 17 | |
| 18 | SERVICE_FILE = "lpcsnoop.service" |
| 19 | SYSTEMD_SERVICE_${PN} += "${SERVICE_FILE}" |
| 20 | SYSTEMD_SUBSTITUTIONS += "SNOOP_DEVICE:${SNOOP_DEVICE}:${SERVICE_FILE}" |
| 21 | SYSTEMD_SUBSTITUTIONS += "POST_CODE_BYTES:${POST_CODE_BYTES}:${SERVICE_FILE}" |
Patrick Venture | 30823b2 | 2018-03-30 11:23:16 -0700 | [diff] [blame] | 22 | |
| 23 | require ${PN}.inc |
| 24 | |
| 25 | S = "${WORKDIR}/git" |
| 26 | |