Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 1 | SUMMARY = "Phosphor Watchdog application" |
| 2 | DESCRIPTION = "Application that implements software watchdog" |
| 3 | HOMEPAGE = "http://github.com/openbmc/phosphor-watchdog" |
| 4 | PR = "r1" |
Patrick Venture | 4e4a296 | 2018-10-01 20:48:41 -0700 | [diff] [blame] | 5 | PV = "1.0+git${SRCPV}" |
Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e" |
Patrick Venture | 4e4a296 | 2018-10-01 20:48:41 -0700 | [diff] [blame] | 8 | |
Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 9 | inherit autotools pkgconfig |
| 10 | inherit obmc-phosphor-dbus-service |
| 11 | |
| 12 | RPROVIDES_${PN} += "virtual/obmc-watchdog" |
| 13 | PROVIDES += "virtual/obmc-watchdog" |
| 14 | |
| 15 | DEPENDS += "autoconf-archive-native" |
| 16 | DEPENDS += "sdbusplus sdbusplus-native" |
William A. Kennington III | 6e1dfdd | 2018-09-13 23:32:19 -0700 | [diff] [blame] | 17 | DEPENDS += "sdeventplus" |
Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 18 | DEPENDS += "phosphor-dbus-interfaces" |
| 19 | DEPENDS += "phosphor-logging" |
| 20 | RDEPENDS_${PN} += "libsystemd" |
| 21 | RDEPENDS_${PN} += "phosphor-logging" |
| 22 | |
| 23 | SRC_URI += "git://github.com/openbmc/phosphor-watchdog" |
Andrew Geissler | 1c6a376 | 2018-10-05 09:20:33 +0000 | [diff] [blame] | 24 | SRCREV = "f505fc0674d5cf14a8b1903cb894e4a171e28400" |
Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 25 | S = "${WORKDIR}/git" |
| 26 | |
| 27 | # Copies config file having arguments for host watchdog |
| 28 | SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/watchdog/poweron" |
| 29 | |
| 30 | # Install the override to set up a Conflicts relation |
| 31 | SYSTEMD_OVERRIDE_${PN} += "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf" |
| 32 | |
| 33 | # For now, watching PowerOn is the only usecase |
| 34 | OBMC_HOST_WATCHDOG_INSTANCES = "poweron" |
| 35 | |
| 36 | # This is really a DBUS service but the service name is |
| 37 | # an argument, so making it this way. |
| 38 | WATCHDOG_TMPL = "phosphor-watchdog@.service" |
Vishwanatha Subbanna | d8b3f61 | 2017-07-03 19:21:18 +0530 | [diff] [blame] | 39 | ENABLE_WATCHDOG_TMPL = "obmc-enable-host-watchdog@.service" |
Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 40 | SYSTEMD_SERVICE_${PN} += "${WATCHDOG_TMPL}" |
| 41 | |
Vishwanatha Subbanna | d8b3f61 | 2017-07-03 19:21:18 +0530 | [diff] [blame] | 42 | # To Enable Host Watchdog early during poweron |
| 43 | SYSTEMD_SERVICE_${PN} += "${ENABLE_WATCHDOG_TMPL}" |
| 44 | |
Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 45 | WATCHDOG_TGTFMT = "phosphor-watchdog@{0}.service" |
Vishwanatha Subbanna | d8b3f61 | 2017-07-03 19:21:18 +0530 | [diff] [blame] | 46 | ENABLE_WATCHDOG_TGTFMT = "obmc-enable-host-watchdog@{0}.service" |
| 47 | |
Andrew Geissler | 510ae37 | 2018-03-27 13:56:26 -0700 | [diff] [blame] | 48 | WATCHDOG_FMT = "../${WATCHDOG_TMPL}:obmc-host-startmin@{1}.target.wants/${WATCHDOG_TGTFMT}" |
| 49 | ENABLE_WATCHDOG_FMT = "../${ENABLE_WATCHDOG_TMPL}:obmc-host-startmin@{0}.target.wants/${ENABLE_WATCHDOG_TGTFMT}" |
Vishwanatha Subbanna | d8b3f61 | 2017-07-03 19:21:18 +0530 | [diff] [blame] | 50 | |
Vishwanatha Subbanna | 55c545a | 2017-06-12 13:09:10 +0530 | [diff] [blame] | 51 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'WATCHDOG_FMT', 'OBMC_HOST_WATCHDOG_INSTANCES', 'OBMC_HOST_INSTANCES')}" |
Vishwanatha Subbanna | d8b3f61 | 2017-07-03 19:21:18 +0530 | [diff] [blame] | 52 | SYSTEMD_LINK_${PN} += "${@compose_list(d, 'ENABLE_WATCHDOG_FMT', 'OBMC_HOST_INSTANCES')}" |