blob: 157d4169bdd0a04abfc65f9c4233677388960580 [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC org.openbmc.control.Chassis example implementation"
2DESCRIPTION = "An example implementation of the org.openbmc.control.Chassis DBUS API."
3PR = "r1"
4
5inherit skeleton-python
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-dbus-service
Brad Bishop86ee1cf2016-06-27 14:53:52 -04007
8RDEPENDS_${PN} += "\
9 python-dbus \
10 python-pygobject \
11 python-netclient \
Brad Bishop1b4e4472016-08-29 21:47:04 -040012 pyphosphor-dbus \
Brad Bishop86ee1cf2016-06-27 14:53:52 -040013 "
14
15SKELETON_DIR = "pychassisctl"
Brad Bishop0fe80462016-08-17 20:27:37 -040016
17FMT = "org.openbmc.control.Chassis@{0}.service"
18DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"