blob: b02b83234f6ec787958455ff4541f4ed86902a28 [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC gdbus library"
2DESCRIPTION = "libopenbmc_intf provides a set of gpio access \
3methods and the GDBUS skeleton code for the org.openbmc DBUS API."
4PR = "r1"
5
6inherit skeleton
Saqib Khanc896e752017-11-13 10:47:54 -06007inherit pkgconfig
Brad Bishop86ee1cf2016-06-27 14:53:52 -04008
9DEPENDS += "glib-2.0"
Matt Spinler728258c2018-08-07 16:35:19 -050010DEPENDS += "cjson"
Brad Bishop86ee1cf2016-06-27 14:53:52 -040011
12SKELETON_DIR = "libopenbmc_intf"
13
Matt Spinler728258c2018-08-07 16:35:19 -050014SRC_URI += "file://gpio_defs.json"
15
Brad Bishop86ee1cf2016-06-27 14:53:52 -040016do_install() {
17 oe_runmake install DESTDIR=${D}
Matt Spinler728258c2018-08-07 16:35:19 -050018
19 install -d ${D}${sysconfdir}/default/obmc/gpio/
20 install -m 0644 ${WORKDIR}/gpio_defs.json ${D}/${sysconfdir}/default/obmc/gpio/
Brad Bishop86ee1cf2016-06-27 14:53:52 -040021}