blob: 5ae6f89b3712fa06f26a967d56abc177cf7bfc9f [file] [log] [blame]
Patrick Venturedb1cc9b2018-09-20 19:27:13 -07001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-blobs"
2SUMMARY = "Phosphor OEM IPMI BLOBS Protocol Implementation"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the BLOB protocol for sending and receiving data over IPMI."
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-host"
Patrick Venture2b120942018-09-27 12:56:49 -070014DEPENDS += "phosphor-logging"
Patrick Venturedb1cc9b2018-09-20 19:27:13 -070015
16S = "${WORKDIR}/git"
17SRC_URI = "git://github.com/openbmc/phosphor-ipmi-blobs"
Andrew Geissler0c39fd82018-10-10 15:50:27 +000018SRCREV = "5c4b17b2c5ae15bfcb92447151863c4ad67f40fa"
Patrick Venturedb1cc9b2018-09-20 19:27:13 -070019
20FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
21FILES_${PN}_append = " ${libdir}/host-ipmid/lib*${SOLIBS}"
22FILES_${PN}_append = " ${libdir}/net-ipmid/lib*${SOLIBS}"
23FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
24
25HOSTIPMI_PROVIDER_LIBRARY += "libblobcmds.so"