Brad Bishop | 93fb535 | 2015-09-09 03:59:20 +0000 | [diff] [blame] | 1 | # Common code for dbus applications using python. |
2 | |||||
3 | inherit allarch | ||||
4 | inherit obmc-phosphor-systemd | ||||
5 | inherit obmc-phosphor-license | ||||
6 | |||||
7 | RDEPENDS_${PN} += "python-dbus python-pygobject" | ||||
8 | SRC_URI += " \ | ||||
9 | file://${PN}.py \ | ||||
10 | " | ||||
11 | S = "${WORKDIR}" | ||||
12 | |||||
13 | do_install_append() { | ||||
14 | # install the script | ||||
15 | install -d ${D}${sbindir} | ||||
16 | install -m 0755 ${WORKDIR}/${PN}.py ${D}${sbindir}/${PN} | ||||
17 | } |