blob: e3c02c2fcc0316c537a2660225dca4212efa929f [file] [log] [blame]
Xo Wang0d917d82016-10-24 18:44:49 -07001DESCRIPTION = "Command line tools for hardware device registers"
2HOMEPAGE = "https://github.com/adurbin/iotools"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
5SRCREV = "452ad1f4957a4f307fbe204419e5d08a1a1febb9"
6SRC_URI = "git://git@github.com/adurbin/iotools.git;protocol=https"
7PV = "v1.6+git${SRCPV}"
8
9S = "${WORKDIR}/git"
10FILES_${PN} = "${sbindir}"
11
12do_compile() {
13 # CC is overridden in the Makefile, so override it harder in the invocation
14 oe_runmake CC="${CC}" DEBUG="${DEBUG_BUILD-0}" STATIC=0
15}
16
17# The "install" make target runs the binary to create links for subcommands.
18# The links are excessive and this doesn't work for cross compiling.
19do_install() {
20 install -d ${D}${sbindir}
21 install -m 0755 iotools ${D}${sbindir}
22}