blob: dc2243acf7b41a0b618b7e191f58c7676785d5ae [file] [log] [blame]
Eddie James1a623ef2018-02-09 11:59:18 -06001SUMMARY = "Insecure private key for testing and development"
2DESCRIPTION = "Do not use this key to sign images."
3PR = "r1"
Patrick Venturee931be72018-11-03 16:33:16 -07004LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
Eddie James1a623ef2018-02-09 11:59:18 -06006
7inherit allarch
8inherit native
Eddie James1a623ef2018-02-09 11:59:18 -06009
10SRC_URI += "file://OpenBMC.priv"
11
12do_install() {
13 bbplain "Using an insecure image signing key!"
14 install -d ${D}${datadir}
15 install -m 400 ${WORKDIR}/OpenBMC.priv ${D}${datadir}
16}