blob: 558690303c21a16af74c6063010f01d5da7af796 [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC org.openbmc.Watchdog example implementation"
2DESCRIPTION = "A sample implementation for the org.openbmc.Watchdog DBUS API."
3PR = "r1"
4
5inherit skeleton-gdbus
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-dbus-service
Brad Bishop86ee1cf2016-06-27 14:53:52 -04007
8SKELETON_DIR = "hostwatchdog"
Brad Bishop0fe80462016-08-17 20:27:37 -04009
10FMT = "org.openbmc.watchdog.Host@{0}.service"
11DBUS_SERVICE_${PN} += "${@compose_list(d, 'FMT', 'OBMC_WATCHDOG_INSTANCES')}"
12SYSTEMD_SERVICE_${PN} += "obmc-start-watchdog@.service obmc-stop-watchdog@.service"
13
14START_TMPL = "obmc-start-watchdog@.service"
15START_TGTFMT = "obmc-chassis-start@{1}.target"
16START_INSTFMT = "obmc-start-watchdog@{0}.service"
17START_FMT = "../${START_TMPL}:${START_TGTFMT}.wants/${START_INSTFMT}"
18
19STOP_TMPL = "obmc-stop-watchdog@.service"
20STOP_TGTFMT = "obmc-chassis-stop@{1}.target"
21STOP_INSTFMT = "obmc-stop-watchdog@{0}.service"
22STOP_FMT = "../${STOP_TMPL}:${STOP_TGTFMT}.wants/${STOP_INSTFMT}"
23
24SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'START_FMT', 'OBMC_WATCHDOG_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"
25SYSTEMD_LINK_${PN} += "${@compose_list_zip(d, 'STOP_FMT', 'OBMC_WATCHDOG_INSTANCES', 'OBMC_CHASSIS_INSTANCES')}"