blob: 7d437cf586ea0db25e5a928aa9b4aeaad3c95631 [file] [log] [blame]
Brad Bishop86ee1cf2016-06-27 14:53:52 -04001SUMMARY = "OpenBMC hwmon poller"
2DESCRIPTION = "OpenBMC hwmon poller."
3PR = "r1"
4
5inherit skeleton-python
Brad Bishop0fe80462016-08-17 20:27:37 -04006inherit obmc-phosphor-systemd
Brad Bishop86ee1cf2016-06-27 14:53:52 -04007
8VIRTUAL-RUNTIME_skeleton_workbook ?= ""
9
10RDEPENDS_${PN} += "\
11 python-dbus \
12 python-json \
13 python-shell \
14 python-pygobject \
15 pyphosphor \
16 ${VIRTUAL-RUNTIME_skeleton_workbook} \
17 "
18
19SKELETON_DIR = "pyhwmon"
Brad Bishop0fe80462016-08-17 20:27:37 -040020TMPL = "mapper-wait@.service"
21TGT = "obmc-fans-ready.target"
22INSTFMT = "mapper-wait@-org-openbmc-sensors-speed-fan{0}.service"
23FMT = "../${TMPL}:${TGT}.wants/${INSTFMT}"
24SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_FAN_INSTANCES')}"