blob: 0a30b7b48837046b4af817100c9582f7a92e7529 [file] [log] [blame]
Cyril Bur9a3f0082017-01-12 18:13:30 +11001SUMMARY = "Phosphor OpenBMC MBOX Daemon"
2DESCRIPTION = "Phosphor OpenBMC MBOX Daemon"
3PR = "r1"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
6
7inherit autotools pkgconfig
8inherit obmc-phosphor-systemd
9
10DEPENDS += "autoconf-archive-native"
Brad Bishop120ebc82018-02-01 10:27:11 -050011
12# Drop gnome-common-native if AX_CODE_COVERAGE ever comes back to
13# autoconf-archive upstream.
14DEPENDS += "gnome-common-native"
15
Andrew Jeffery928084f2017-04-21 10:18:24 +093016DEPENDS += "systemd"
Patrick Williamsea61a042017-06-30 12:01:49 -050017DEPENDS += "phosphor-logging"
Andrew Jefferyaef4ced2017-04-18 16:30:10 +093018RDEPENDS_${PN} += "libsystemd"
Cyril Bur9a3f0082017-01-12 18:13:30 +110019
20S = "${WORKDIR}/git"
21
Adriana Kobylakbb6679e2017-06-10 09:47:58 -050022SRC_URI += "git://github.com/openbmc/phosphor-mboxd.git"
Cyril Bur9a3f0082017-01-12 18:13:30 +110023
24SRC_URI += "file://99-aspeed-mbox.rules"
Andrew Jefferya944a4b2017-01-25 13:17:13 +103025SRC_URI += "file://99-aspeed-lpc-ctrl.rules"
Cyril Bur9a3f0082017-01-12 18:13:30 +110026SRC_URI += "file://aspeed-lpc-ctrl-h.patch"
27
Andrew Geissler40929a52018-02-21 23:40:10 +000028SRCREV="cafb002ebcbe8c9a828a1b3c15d2f9b95fb7e9ec"
Andrew Jefferyaef4ced2017-04-18 16:30:10 +093029
30PROVIDES += "mboxctl"
Cyril Bur9a3f0082017-01-12 18:13:30 +110031
32MBOXD_FLASH_SIZE ??= "32M"
33SYSTEMD_SUBSTITUTIONS += "FLASH_SIZE:${MBOXD_FLASH_SIZE}:${PN}.service"
34
35# Hacks because ${STAGING_KERNEL_DIR} points to the kernel source tree, not the
36# installed, pre-processed headers. Requires the aspeed-lpc-ctrl-h patch above.
Saqib Khanbe0ee8e2017-03-09 10:28:09 -060037CFLAGS_append = " -I include"
Cyril Bur9a3f0082017-01-12 18:13:30 +110038
39do_install_append() {
40 install -d ${D}/lib/udev/rules.d
41 install -m 0644 ${WORKDIR}/99-aspeed-mbox.rules ${D}/lib/udev/rules.d
Andrew Jefferya944a4b2017-01-25 13:17:13 +103042 install -m 0644 ${WORKDIR}/99-aspeed-lpc-ctrl.rules ${D}/lib/udev/rules.d
Cyril Bur9a3f0082017-01-12 18:13:30 +110043}
Matt Spinlerf96194c2017-01-20 15:32:07 -060044
45TMPL = "mboxd-reload@.service"
Andrew Geissler4a9dbb22017-07-25 09:12:37 -050046TGTFMT = "obmc-chassis-poweron@{0}.target"
Matt Spinlerf96194c2017-01-20 15:32:07 -060047INSTFMT = "mboxd-reload@{0}.service"
48FMT = "../${TMPL}:${TGTFMT}.wants/${INSTFMT}"
49
50SYSTEMD_SERVICE_${PN} += "mboxd.service"
51SYSTEMD_SERVICE_${PN} += "mboxd-reload@.service"
52SYSTEMD_LINK_${PN} += "${@compose_list(d, 'FMT', 'OBMC_CHASSIS_INSTANCES')}"
Deepak Kodihallie1aa7fd2017-06-29 09:56:24 -050053
Brad Bishop168ce612018-03-09 00:40:41 -050054# Enable virtual-pnor by DISTRO_FEATURE openpower-ubi-fs.
55PACKAGECONFIG_append_df-openpower-ubi-fs = "virtual-pnor"
Patrick Williams6d641c52017-08-09 16:36:51 -050056PACKAGECONFIG[virtual-pnor] = "--enable-virtual-pnor,--disable-virtual-pnor"