blob: c0cea9cb8ecb95a9dfb052f370ac44f8d62ec400 [file] [log] [blame]
Marri Devender Raob0e77ac2019-03-13 08:26:46 -05001SUMMARY = "Phosphor certificate manager configuration for a bmcweb service"
2
3PR = "r1"
4
5LICENSE = "Apache-2.0"
6LIC_FILES_CHKSUM = "file://${PHOSPHORBASE}/LICENSE;md5=19407077e42b1ba3d653da313f1f5b4e"
7
8RDEPENDS_${PN} = "phosphor-certificate-manager"
9
10inherit allarch
11
12SRC_URI = "file://env"
13
14do_install() {
15 install -D ${WORKDIR}/env ${D}/${sysconfdir}/default/obmc/cert/bmcweb
16}
17
18pkg_postinst_${PN}() {
19 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@bmcweb.service"
20 TARGET="../phosphor-certificate-manager@.service"
21 mkdir -p $D$systemd_system_unitdir/multi-user.target.wants
22 ln -s $TARGET $LINK
23}
24
25pkg_prerm_${PN}() {
26 LINK="$D$systemd_system_unitdir/multi-user.target.wants/phosphor-certificate-manager@bmcweb.service"
27 rm $LINK
28}