Adriana Kobylak | 39b1ff0 | 2020-07-12 15:12:36 -0500 | [diff] [blame] | 1 | SUMMARY = "Provides a host firmware image" |
| 2 | DESCRIPTION = "Use a bbappend to add the image files" |
| 3 | PR = "r1" |
| 4 | |
| 5 | inherit allarch |
| 6 | inherit deploy |
| 7 | |
| 8 | HOSTFW_LICENSE ?= "Apache-2.0" |
| 9 | HOSTFW_LIC_FILES_CHKSUM ?= "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 10 | |
| 11 | LICENSE = "${HOSTFW_LICENSE}" |
| 12 | LIC_FILES_CHKSUM = "${HOSTFW_LIC_FILES_CHKSUM}" |
| 13 | |
| 14 | do_compile_prepend() { |
| 15 | # The image directory can be used as the source to create a filesystem to |
| 16 | # add to the BMC image. |
| 17 | install -d ${B}/image |
| 18 | |
| 19 | # Install an image-hostfw file in the update directory to be included in |
| 20 | # the code update tarball. |
| 21 | install -d ${B}/update |
| 22 | } |
| 23 | |
| 24 | do_deploy() { |
| 25 | install -d ${DEPLOYDIR}/hostfw/image |
| 26 | install -d ${DEPLOYDIR}/hostfw/update |
| 27 | cp -R --no-dereference --preserve=mode,links ${B}/image/ ${DEPLOYDIR}/hostfw/image/ |
| 28 | cp -R --no-dereference --preserve=mode,links ${B}/update/ ${DEPLOYDIR}/hostfw/update/ |
| 29 | } |
| 30 | |
| 31 | addtask deploy before do_build after do_compile |